Excel de Formül ile Minimum Maksimum ve Ortalama Bulma

Excel de Formül ile Minimum Maksimum ve Ortalama Bulma

Excel de özet tablo (pivot tablo) kullanmadan minimum, maksimum ve ortalama hesaplama bazı durumlarda gerekli olabilir. Özellikle değerler değiştikçe her defasında özet tabloda yenile yapmak istenmemesi veya yenileme işleminde bazen yaptığımız bazı biçimlerdirmelerde bozulabilir. Bu olumsuzlukları gidermek için özet tablo kullanmak yerine formül kullanmak tercih edilebilir.

Örnek olarak meyve ve mevye fiyatlarının olduğu aşağıdaki gibi bir tablo için mevyelere göre özet tablo yapmak gerekebilir.

Mevyelere göre minumum, maksimum ve ortalama fiyat bulmak istenirse aşağıdaki formül ile bu işlemleri yapabiliriz. Bu işlemde en önemli püf nokta formüller köşeli parantez içinde olması gerekir.

Köşeli parantez için excel formül çubuğuna tıkladıktan sonra Shift+Ctrl+Enter tuş kombinasyonu kullanılması gerekmektedir. 

MEYVE FİYAT
ELMA 40
ELMA 70
ELMA 10
ELMA 50
ELMA 10
ARMUT 70
ARMUT 22
ARMUT 40
ARMUT 30
ARMUT 43
ÜZÜM 53
ÜZÜM 20
ÜZÜM 33
ÜZÜM 50

 {=MİN(EĞER(A2:A15=D3;B2:B15))}

{=MAK(EĞER(A2:A15=D3;B2:B15))}

{=ORTALAMA(EĞER(A2:A15=D3;B2:B15))} 

ÖZET TABLO
MEYVE MİNİMUM MAKSİMUM ORTALAMA
ARMUT 22 70 41
ÜZÜM 20 53 39
ELMA 10 70 36

Örnek Excel Dosyası Linki 


İlgili Yazılar